[BlueBream] bluebream beginner get's problem sampleproject to run

Christophe Combelles ccomb at free.fr
Sat May 29 12:58:53 EDT 2010

Le 29/05/2010 15:33, Tamer Higazi a écrit :
> Hi people!
> I have set up a bluebream project (working out the documentation) and
> tried to bootstrap the project and get this error:
> tamer at tux /tmp/sampleproject $ python bootstrap.py
> Traceback (most recent call last):
>    File "bootstrap.py", line 116, in<module>
>      ws.find(pkg_resources.Requirement.parse(requirement)).location
> AttributeError: 'NoneType' object has no attribute 'location'
> Has anybody of you an idea what it could be?!

Looks like a bug related to setuptools.
Make sure you work in an isolated virtualenv.

$ virtualenv --no-site-packages --distribute sandbox
$ sandbox/bin/python bootstrap.py
$ ./bin/buildout

If it still doesn't work, upgrade your version of virtualenv, then try again.


(hoping we are one day be able to get out of the HELL of packaging and 
installation problems in python)

> Tamer
> _______________________________________________
> bluebream mailing list
> bluebream at zope.org
> https://mail.zope.org/mailman/listinfo/bluebream

More information about the bluebream mailing list