[Checkins] SVN: zope.app.undo/branches/nikhil_n-py25/src/zope/app/undo/__init__.py made zope.app.undo work with Python 2.5

Zvezdan Petkovic zvezdan at zope.com
Sat Jul 7 18:40:14 EDT 2007


I don't want to be picky, but I really don't see the advantage of using

	if <boolean expression>:
		return True
	return False

below, when

	return <boolean expression>

will do just fine.

Also it would be nice to reconsider earlier suggestions from Benji and 
Christian about startswith() and readability.

Best regards,

	Zvezdan
 
On Saturday 07 July 2007 12:35, nikhil n wrote:
> Log message for revision 77578:
>   made zope.app.undo work with Python 2.5
>
> Changed:
>   U  
> zope.app.undo/branches/nikhil_n-py25/src/zope/app/undo/__init__.py
>
> -=-
> Modified:
> zope.app.undo/branches/nikhil_n-py25/src/zope/app/undo/__init__.py
> ===================================================================
> ---
> zope.app.undo/branches/nikhil_n-py25/src/zope/app/undo/__init__.py	20
>07-07-07 16:28:02 UTC (rev 77577) +++
> zope.app.undo/branches/nikhil_n-py25/src/zope/app/undo/__init__.py	20
>07-07-07 16:35:12 UTC (rev 77578) @@ -88,7 +88,7 @@
>                  return True
>              return False
>          except AttributeError:
> -            if other and unicode(other[:len(self)]).__eq__(self) ==
> 1: +            if other and unicode(other[:len(self)]).__eq__(self):
> return True
>              return False
>
>
> _______________________________________________
> Checkins mailing list
> Checkins at zope.org
> http://mail.zope.org/mailman/listinfo/checkins


More information about the Checkins mailing list