[Checkins] SVN: Products.ZNagios/branches/frisi-multizeo/ changed uptime to days

Harald Friessnegger harald at webmeisterei.com
Tue Nov 17 06:55:16 EST 2009


Log message for revision 105753:
  changed uptime to days

Changed:
  U   Products.ZNagios/branches/frisi-multizeo/CHANGES.txt
  U   Products.ZNagios/branches/frisi-multizeo/Products/ZNagios/munin_client.py
  U   Products.ZNagios/branches/frisi-multizeo/README.txt

-=-
Modified: Products.ZNagios/branches/frisi-multizeo/CHANGES.txt
===================================================================
--- Products.ZNagios/branches/frisi-multizeo/CHANGES.txt	2009-11-17 09:56:22 UTC (rev 105752)
+++ Products.ZNagios/branches/frisi-multizeo/CHANGES.txt	2009-11-17 11:55:16 UTC (rev 105753)
@@ -4,6 +4,12 @@
 0.4 - unreleased
 ----------------
 
+- uptime is given in days now, instead of seconds which is much more readable
+  `varnish_ plugin`_ does this too
+
+  .. _`varnish_ plugin`: http://varnish.projects.linpro.no/browser/trunk/varnish-tools/munin/varnish_
+  [fRiSi]
+
 - `zeo_munin.py` can handle multiple Databases now
   [fRiSi]
 

Modified: Products.ZNagios/branches/frisi-multizeo/Products/ZNagios/munin_client.py
===================================================================
--- Products.ZNagios/branches/frisi-multizeo/Products/ZNagios/munin_client.py	2009-11-17 09:56:22 UTC (rev 105752)
+++ Products.ZNagios/branches/frisi-multizeo/Products/ZNagios/munin_client.py	2009-11-17 11:55:16 UTC (rev 105753)
@@ -86,7 +86,12 @@
 
 
 class uptime(SimpleGraph):
+    """uptime in days"""
 
+    def do_fetch(self):
+        #value is provided in seconds, convert it to days
+        print "%s.value %.3f" % (self.name, self.data[self.key]/86400)
+
     key = name = 'uptime'
     title = 'Uptime'
 

Modified: Products.ZNagios/branches/frisi-multizeo/README.txt
===================================================================
--- Products.ZNagios/branches/frisi-multizeo/README.txt	2009-11-17 09:56:22 UTC (rev 105752)
+++ Products.ZNagios/branches/frisi-multizeo/README.txt	2009-11-17 11:55:16 UTC (rev 105753)
@@ -32,18 +32,13 @@
 ``````````````````````````````````
 
 uptime
-  uptime of the zope instance in seconds
+  uptime of the zope instance in days (1 hour is 0.041)
 
-  XXX shouldn't we change this to days? (much more readable, `varnish_ plugin`_ does this too)
-
-  .. _`varnish_ plugin`: http://varnish.projects.linpro.no/browser/trunk/varnish-tools/munin/varnish_
-
 refcount
   XXX help document
 
 errors
   total number of errors, conflicts and unresolved conflicts
-  that occured since last startup
 
 activity
   nr of object loads, stores and



More information about the checkins mailing list