[Grok-dev] Re: grok.layer branch

Philipp von Weitershausen philipp at weitershausen.de
Tue Apr 17 14:08:32 EDT 2007

On 17 Apr 2007, at 19:59 , Kevin Smith wrote:
> I'd like to hear some more grokkers weigh in on grok.layer vs.  
> grok.request, I'd like to get this out the door today if possible. :)

Just chatted with Martijn. We came to a conclusion that grok.layer()  
would probably yield the best code readability which weights higher  
than the actual symmetry. So, let's go with grok.layer then.

Thanks for doing this. Let me know when you think your branch is  
ready, I'll be happyt to review it.

> I prefer grok.layer because IMO it has more narrowly implied  
> definition whereas grok.request has a wider implied definition ( I  
> expect it to do more than just assign layers, if even that. )

Well, it's not about *assigning* layers or anything. It's about  
expressing a constraint. So, we should at least document it clearly  
that grok.layer() ends up being a constraint on the 'request' of  

More information about the Grok-dev mailing list