[Grok-dev] Re: buildout and download errors [was: admin-UI: merge tonight]

Philipp von Weitershausen philipp at weitershausen.de
Thu Aug 16 08:49:00 EDT 2007

On 16 Aug 2007, at 14:41 , Uli Fouquet wrote:
> Am Donnerstag, den 16.08.2007, 12:10 +0200 schrieb Philipp von
> Weitershausen:
>>> This is your last chance for complaints ;-)
>> Here's one: I get a test failure (this is after an 'svn up' and
>> bin/buildout -n):
> Thanks for the report, Philipp! The tests seem to work properly :-)
> I fixed that. It was caused by changed behaviour of martian.scan,  
> which
> does not scan 'test*' directories any more, right?

I suppose that's right. Thanks for fixing. I can confirm it works now.

> My main failure, however, was, that I did not properly updated the
> installed eggs before checking in.
> This in turn was caused by my laziness and the problems I run into  
> when
> I start 'buildout -n'. Buildout then will start to check installed  
> eggs,
> but after a few eggs it constantly runs into 'download errors' of
> different types: somtimes I get '403 forbidden', most often simply :
> 	Download error: (-2, 'Name or service not known')

I have never experiences this problem. It smells like a connection or  
DNS failure of some sort.

> This is *not* reproducable in a strict manner. When I restart the
> procedure, buildout will hang at a different or the same location  
> (egg)
> with a different (or same) error message. Unpredictable and nearly no
> chance to go through the whole process :-/ (sidenote: during buildout
> runs the network is nearly unreachable for other clients/services).
> My 'solution' for that is rather time consuming: I delete or move all
> eggs and start over with an empty eggs directory, doing 'buildout'
> without '-n' option.

It seems strange that you have to get rid of all the existing eggs.  
You probably don't have to do that, especially since below you write  
that buildout *can* resume an aborted installation (which to my  
experience works very well).

> I then run into the same (unpredictable) errors,
> but when I restart buildout, already fetched eggs won't be fetched
> again, eggs which in the last run raised a download error might  
> properly
> be fetched and so I have a chance to complete the whole process (after
> 30+ restarts of buildout).
> Is this is a bug? Am I the only one with that problems? Do I have a
> weird network setup? Should I change my buildout setup?

I have no idea what the problem is. Is anybody else getting these  
problems? I certainly have never seen them, not on my machine nor on  

What's your ~/.buildout/default.cfg?

By the way, a *great* way to speed up the "buildout -n" process or  
the first time buildout runs is to use ppix, http://download.zope.org/ 
ppix (the page constains instructions on how to use it with Buildout).

More information about the Grok-dev mailing list