[Grok-dev] Re: Bug on Linux and Windows [was: Bug on windows]

Philipp von Weitershausen philipp at weitershausen.de
Sun Aug 19 07:26:17 EDT 2007

Uli Fouquet wrote:
> Hello Grokkers,
> Am Donnerstag, den 16.08.2007, 15:19 +0200 schrieb Max M: 
>> While:
>>    Installing.
>>    Getting section app.
>>    Initializing section app.
>>    Loading zc.buildout recipe entry zc.zope3recipes>=0.5.3:application.
>> An internal error occured due to a bug in either zc.buildout or in a
>> recipe being used:
>> ImportError:
>> No module named schemaless
>> Is there any restrictions on where the egss should be placed? I just 
>> chose the default location.
> the same error appeared yesterday on a *Linux* machine of one of the
> guys of the local user group. He is reading this list, so he might give
> more infos himself. This seems not to be a windows-only problem.

Right. It happens when you have an existing but older ZConfig version on 
  your PYTHONPATH. I've filed a zc.buildout bug report: 

> Later on I ran into similar trouble myself, when trying to buildout the
> martian package:
> -------------------------------
> $ ./bin/buildout 
> Develop: '/home/uli/WorkShop/devel/zope/grok/tmp/martian/.'
> While:
>   Installing.
>   Getting section test.
>   Initializing section test.
>   Loading zc.buildout recipe entry zc.recipe.testrunner:default.
> An internal error occured due to a bug in either zc.buildout or in a
> recipe being used:
> DistributionNotFound:
> zope.testing
> --------------------------------
> The funny thing is, that zope.testing was available in the standard eggs
> dir. The other guy with the 'schemaless' problem also had ZConfig (the
> package containing schemaless) installed. So, why could buildout not
> find those already installed packages/modules?
> I tried to investigate, placed the zope.testing egg at every location,
> you can think of, tried to include it in setup.py/buildout.cfg but no
> success :-/ Also quite strange: I have *no* problems at all with grok
> buildouts, which use zope.testing and the same eggs directory as well. 
> BTW: I could circumvent my problem by setting the PYTHONPATH to the
> zope.testing egg when running buildout.
> Any ideas anybody?

I can't reproduce this at all and I've never seen anything like it. I 
don't want to be too dismissive, but it smells like a weird setup 
problem on your end.

http://worldcookery.com -- Professional Zope documentation and training

More information about the Grok-dev mailing list