[Grok-dev] Re: Heads up: applyChanges in EditForms changed
faassen at startifact.com
Fri Mar 16 09:44:16 EDT 2007
Philipp von Weitershausen wrote:
> On 16 Mar 2007, at 07:55 , Martijn Faassen wrote:
>> Philipp von Weitershausen wrote:
>>> From the log message:
>>> - I renamed applyChanges to apply_changes to match our PEP8 fetish
>> Wait, wait, I thought we didn't follow PEP 8's naming convention for
>> methods at all, but were sticking to Zope 3 conventions! We're
>> certainly not being very consistent if we're to stick with underscores
>> in naming - much of Grok's own classes use camelCasing for methods.
> Looking at the interfaces, I can't see much evidence of camelCasing, but
> I *can* see evidence of
> - grok.global_utility
> - grok.local_utility
> - grok.define_permission
> That looks quite PEP8ish. But perhaps I misunderstood when we discussed
> that at the sprint.
These aren't methods though. I'm not sure what the Zope 3 conventions
are for module-level things like annotations, if any.
More information about the Grok-dev