[Grok-dev] naming conventions
ct at gocept.com
Fri Mar 16 11:27:19 EDT 2007
I didn't catch your discussion and couldn't read up on the other thread,
so I'm running on the danger to be missing something and I'm sorry for
I'm not sure what the naming conventions for Zope 3 are, but, Jim keeps
referring to PEP 8 and keeps pointing out that those do you use
under_scores in favour of camelCase for methods and attribute names.
Am Freitag, den 16.03.2007, 16:06 +0100 schrieb Martijn Faassen:
> Hi there,
> Philipp and I had some discussion about naming conventions as a result
> of the applyChanges versus apply_changes debate. We've decided to go
> back to the Zope 3 conventions for method names. I've checked in a file
> in doc/naming_conventions.txt which describes our naming conventions.
> For class annotations (grok.local_utility) we break with Zope 3
> tradition and use underscores.
> The only decision still deferred is what naming convention to use for
> top level functions in modules (that are not defining class
> annotations). Zope uses camelCase (getUtility). Grok internally now uses
> under_scores, but we don't expose those yet to the outside world. What
> to do here? Perhaps we'll defer the discussion until we actually have
> some non-class annotation top-level functions to expose.
> Grok-dev mailing list
> Grok-dev at zope.org
gocept gmbh & co. kg - forsterstraße 29 - 06112 halle/saale - germany
www.gocept.com - ct at gocept.com - phone +49 345 122 9889 7 -
fax +49 345 122 9889 1 - zope and plone consulting and development
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 189 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
Url : http://mail.zope.org/pipermail/grok-dev/attachments/20070316/a6cb4149/attachment.bin
More information about the Grok-dev