[Grok-dev] Re: IErrorReportingUtility component lookup error

Uli Fouquet uli at gnufix.de
Fri Oct 12 21:45:47 EDT 2007

Martijn Faassen wrote:

> I'm not sure I understand entirely. but I know that 
> zope.app.error/zope.error has been the source of errors before, as 
> someone decided to refactor zope.app.error into zope.error and *then* 
> make a final zope.app.error 2.4 release (and zope.error 2.4 release).

Ah! Thanks for the info! I assume, you meant 3.4. That (mixed up with
other reasons) might be the main reason for our trouble.

> Perhaps we can make it work by upgrading to a newer version of 
> zope.app.publication? Oh, but you say you downgrade it to make things 
> work? This whole situation is rather frustrating...

For zope.app.publication there is no newer version, I'm afraid. But, as
I believe now, zope.app.publication is not to blame. Please see below.

> Anyway, someone needs to dig into the history of all this and report 
> back which versions of which packages we should be using that makes this 
> problem go away. Downgrading zope.app.publication to an earlier version 
> seems to be the wrong way to go about it. What about comparing with the 
> versions.cfg of the Grok trunk? Does the problem happen there?

Checked it: no problems there :-) 

To summarize: zope.app.error 3.5.1 seems to be needed.

The details:

After digging deeper: the problem seems to happen when authentication
takes place and it seems in fact to result from different zope.app.error

Luciano: if you try to fetch any non-existent or 'forbidden' page, you
should get the same error. So, it is not admin-UI specific :-)

The error only happens when zope.app.error < 3.5.1 is used. Luciano,
reading your commandline dump I assume, you used a grokproject
environment (and not a trunk checkout), right?

When using grokproject, it seems that zope.app.error 3.4.1 is picked by
buildout, which gives the lookup error. Because I am a buildout
illiterate, I do not understand completely why with grokproject this old
version is used, even if 3.5.1 is installed (and marked stable). 

Well, it might be caused by the fact, that in the buildout.cfg template
of grokproject http://download.zope.org/distribution/ is given as link
source and on this list, the 3.5.1 version is still missing (on
http://download.zope.org/ppix it's available).

The grok trunk itself pinned version 3.5.1 for zope.app.error, so here
the error does not happen (good job, guys!).

	zope.app.error = 3.5.1

into my grokproject's buildout.cfg and running::

	$ bin/buildout

helped here.

Kind regards,


More information about the Grok-dev mailing list