[Grok-dev] "baseclass" or "ignore"?

Brandon Craig Rhodes brandon at rhodesmill.org
Thu Oct 25 08:53:40 EDT 2007


While reading template code, it occurred to me that:

    class MyClass(...):
        grok.ignore()

is more readable than:

    class MyClass(...):
        grok.baseclass()

which seems to communicate something one step removed from what the
directive is really going to do.  I suppose I'm going to receive the
objection that things are nice the way things are and that if clarity
were our aim we would have to say: :-)

    class MyClass(...):
        grok.dont_grok_this_class_but_still_grok_its_subclasses()

-- 
Brandon Craig Rhodes   brandon at rhodesmill.org   http://rhodesmill.org/brandon


More information about the Grok-dev mailing list