[Grok-dev] Re: "baseclass" or "ignore"?

Jan-Wijbrand Kolman janwijbrand at gmail.com
Fri Oct 26 02:48:24 EDT 2007


Brandon Craig Rhodes wrote:
> While reading template code, it occurred to me that:
> 
>     class MyClass(...):
>         grok.ignore()
> 
> is more readable than:
> 
>     class MyClass(...):
>         grok.baseclass()
> 
> which seems to communicate something one step removed from what the
> directive is really going to do.  I suppose I'm going to receive the
> objection that things are nice the way things are and that if clarity
> were our aim we would have to say: :-)
> 
>     class MyClass(...):
>         grok.dont_grok_this_class_but_still_grok_its_subclasses()

Besides the loss of symetry with the class name convention we have, I 
just thought about the following:

Currently the directives have a "declarative" nature as I see it. They 
say something about the class and what it is. They're not so much actual 
instructions for Grok. Grok "just" knows how to interpret the 
declarations and acts on it.

So, if people really think something with "ignore" in it will read more 
clearly than "grok.baseclass()", then at least I think it should be 
"grok.ignored()".


kind regards,
jw



More information about the Grok-dev mailing list