[Grok-dev] Re: "baseclass" or "ignore"?

Martijn Faassen faassen at startifact.com
Fri Oct 26 10:21:57 EDT 2007

Jan-Wijbrand Kolman wrote:
> Besides the loss of symetry with the class name convention we have, I 
> just thought about the following:
> Currently the directives have a "declarative" nature as I see it. They 
> say something about the class and what it is. They're not so much actual 
> instructions for Grok. Grok "just" knows how to interpret the 
> declarations and acts on it.
> So, if people really think something with "ignore" in it will read more 
> clearly than "grok.baseclass()", then at least I think it should be 
> "grok.ignored()".

I think this is a good point. I'm -1 to changing this to grok.ignore(). 
Also -1 to grok.ignored(), which would indeed be a better name as it's 
more consistent with the other directives.

If someone can point out a use case where they wish to use 
grok.baseclass() while what they're implementing is not intended to be a 
baseclass, that would be a good argument for changing this. If not, I 
think we should stick with what we have.



More information about the Grok-dev mailing list