[Grok-dev] Re: zc.sourcefactory

Sebastian Ware sebastian at urbantalk.se
Mon Sep 3 05:33:12 EDT 2007

Maybe this previous thread might help. /Sebastian

Previously Martijn Faassen wrote:

> Wichert Akkerman wrote:
>> Buildout tells me this:
>> Error: There is a version conflict.
>> We already have: zope.app.keyreference 3.5.0b1
>> but grok 0.9dev-r78980 requires 'zope.app.keyreference==3.4.0a1'.
>> which means you can not create a grok buildout at the moment.
> Interesting. This is with the recent SVN version? I changed some  
> version
> requirements recently but didn't run into this running my buildout.
> I just tried a fresh checkout and a buildout -n, but grok installs
> correctly.
> Could you tell me the exact steps you do in order to reproduce this  
> problem?

I blew away my buildout cache and it works now. Philipp suggested that I
may have been bitten by the "newest = False" in buildout.cfg. That be
true - I keep forgetting that setting is there.


3 sep 2007 kl. 11.20 skrev Jan Ulrich Hasecke:
> I would write a howto, but first of all I plead to call buildout sid.
> I get this error while calling buildout in my grokproject:
> Error: There is a version conflict.
> We already have: ZODB3 3.9.0-dev-r77011
> but grok 0.10 requires 'ZODB3==3.8.0b2'.
> j"neverhadnoproblemswithbuildout"uh
> _______________________________________________
> Grok-dev mailing list
> Grok-dev at zope.org
> http://mail.zope.org/mailman/listinfo/grok-dev

More information about the Grok-dev mailing list