[Grok-dev] Grok 0.12 should now be fixed

Martijn Faassen faassen at startifact.com
Tue Apr 22 18:19:54 EDT 2008

Hi there,

Thanks to Ethan Jucovy, Jasper Spaans and Brandon Craigh Rhodes on 
#grok, we tracked down the problem in Grok 0.12.

We were using z3c.autoinclude 2.1. This worked fine on some systems 
(such as those with a hand-compiled Python) but failed on some systems 
(at least some versions of Ubuntu and Debian), as the system-supplied 
packages had not enough information in them. Since I was using a 
hand-compiled Python to test (I suspect Jan-Wijbrand as well), I never 
saw this problem. Ethan didn't run into this problem as well on his system.

Ethan released z3c.autoinclude 2.2, which should work around this 
problem. (it worked for Jasper)

I've been somewhat naughty and updated only the online versions list of 
Grok 0.12, not done a new release. This because there was actually no 
code change in Grok. As soon as everybody runs grokproject, or when you 
run bin/buildout, you should be using the new version of z3c.autoinclude.



More information about the Grok-dev mailing list