[Grok-dev] Re: megrok.form errors

Dirceu Pereira Tiegs dirceutiegs at gmail.com
Wed Apr 23 23:51:27 EDT 2008

Em 23/04/2008, às 20:15, Martijn Faassen escreveu:
> Hi there,

Hi Martijn,

> Thanks for the report - this exactly the kind of feedback we need to  
> track down problems.
> Lacko Roman wrote:
> > Sorri, forget to say, a put one extra requirement into setup.py:
> >         ...
> >         # Add extra requirements here
> >         'megrok.form',
> >         ...
> [snip useful conflict error traceback]
> > But When I removed zcml instruction "<includeDependencies  
> package="." />"
> > from src\klucsite\configure.zcml Zope started successfully
> The odd thing is that I tested exactly the megrok.form scenario  
> before the release (and just now again), so now I'm wondering what  
> went wrong... Ah, I think I figured it out, see below.
> I just reproduced it! Your conflict error messages luckily had the  
> versions of the eggs you were using, and I noticed that my eggs have  
> different versions...
> I was using the ugly version zc.datetimewidget 0.6.1dev-r72453. You  
> were using a more proper release, 0.5.2. I don't know where I got  
> 0.6.1dev from, probably got it somewhere long ago, as it doesn't  
> seem to appear on PyPI. When I made 0.5.2 a requirement, I got the  
> same error.

That's very strange. I've created a virtualenv environment and, when I  
put 'zc.datetimewidget' as a requirement, buildout downloads  
zc.datetimewidget version 0.6.1dev-r72453. I cannot find it on PyPI.  
Why it's been downloaded? It's not even on svn.zope.org - the latest  
version there is 0.6.0dev.

> When I remove the auto-inclusion and put in this instead (which is  
> what the includeDependencies directive actually does):
> <include package="megrok.form" />
> ...I get the same error. So this doesn't appear to be triggered by  
> auto-inclusion, but is seems to be a problem with megrok.form.
> The strange thing is that 0.5.2 *is* the latest public release and  
> it's months old, so I'm rather confused as to why nobody ran into  
> this one before. Dirceu, what version of megrok.form are you using  
> for developing?

I assume you're asking for zc.datetimewidget version - I was using  

> Anyway, the fix appears to be that megrok.form is doing a  
> registration that zc.datetimewidget is *also* doing, so Dirceu  
> should be able to fix this one easily.
> Anyway, if I'm right, that concludes this immediate question: I  
> recommend to you wait until Dirceu makes a new release with the fix.  
> It's not a 0.12 problem, it's not an auto-inclusion problem, but it  
> appears to be a megrok.form problem.

Actually it's a zc.datetimewidget 0.5.2 problem :-). Version 0.5.2  
overrides.zcml is different from version 0.6.1dev and it conflicts  
with zope.app.form-3.4.0b2's configure.zcml. I've fixed it in  
megrok.form by not calling zc.datetimewidget.overrides.zcml and by  
configuring those things in megrok.form.overrides.zcml.

I think this should be fixed on zc.datetimewidget, but I think I don't  
have the privileges to upload a new egg.

> Now on to the wider problem this demonstrates, for everybody to  
> think about, and for Dirceu in particular:
> All this is again a good argument for version pinning. If Dirceu  
> would somehow supply exactly the versions *he* is using to all users  
> of megrok.form, then everybody would either get the same error, or  
> none at all.

Yes, you're right. I made new releases of megrok.form and  
collective.namedblobfile supplying versions for every dependency.  
Sorry about this.

Dirceu Pereira Tiegs
Weimar Consultoria

Hospedagem Plone, Zope e Python

More information about the Grok-dev mailing list