[Grok-dev] could we re-name grok.IRESTRequest to grok.IRESTLayer?

Brandon Craig Rhodes brandon at rhodesmill.org
Wed Dec 17 10:32:53 EST 2008

Brandon Craig Rhodes <brandon at rhodesmill.org> writes:

> the way that an `IRESTRequest` is actually used, always, and in every
> context that I can find it used, is as a base class for a REST layer.
> Therefore, I think that it should be renamed to `IRESTLayer`, and that
> `IRESTRequest` should be left around as a synonym to avoid breaking
> old code that has already used that name - but that the name should be
> put through deprecation, either now, or some time after 1.0.

Wait - it looks like more needs to be said: an argument could be made
either for renaming it to `IRESTLayer`, or to `IRESTSkin`, and I cannot
tell which is the preferred terminology.  If we are going to keep the
directive named `grok.restskin()`, then we should really name the
interface `IRESTSkin` to match.  But the rest of our code and comments
seems to prefer then name "layer" for these things.  I would like the
code base to become consistent, so that there aren't three names for
something to confuse me.  Which should we use?  The name "skin" is odd
because skins are normally thought of as changing the appearance of a
web page or application but without changing any of its buttons,
sliders, or displays; and REST skins certainly change the calls and
information that one can get from an object!  The name "layer" is odd
because you can't pile these on top of each other like, well, like you
can with layers. :-) (Or can you?)  Anyway, let me know which is the
preferred terminology, and we can deprecate the old.

Brandon Craig Rhodes   brandon at rhodesmill.org   http://rhodesmill.org/brandon

More information about the Grok-dev mailing list