[Grok-dev] could we re-name grok.IRESTRequest to grok.IRESTLayer?

Brandon Craig Rhodes brandon at rhodesmill.org
Wed Dec 17 15:28:26 EST 2008

Jan-Wijbrand Kolman <janwijbrand at gmail.com> writes:

> -1 on the rename.
> Rationale: The naming scheme is *intentionally* similar ... because
> ... the mechanisms are similar to a great great extend. ... As such it
> is way easier to understand (at least that is how I experienced it),
> how REST "views" actually works.

-1 on naming things according to how they work behind the scenes, if it
means the name tells programmers nothing about how the class is supposed
to be *used* in Grok applications. ;-)

If the symbol we are discussing is supposed to be used in developer
application code - which, I believe, this one is - then we need to name
it to make their code make sense, not ours; otherwise we are kind of
throwing out the point of Grok, which is to make web developers' code
make sense.  If the name "IRESTRequest" tells *us* how it works, but
"IRESTLayer" tells *them* what they're supposed to do with it, then I
think we should opt for the latter every time.

Brandon Craig Rhodes   brandon at rhodesmill.org   http://rhodesmill.org/brandon

More information about the Grok-dev mailing list