[Grok-dev] could we re-name grok.IRESTRequest to grok.IRESTLayer?

Brandon Craig Rhodes brandon at rhodesmill.org
Wed Dec 17 15:30:58 EST 2008

Brandon Craig Rhodes <brandon at rhodesmill.org> writes:

> If the name "IRESTRequest" tells *us* how it works, but "IRESTLayer"
> tells *them* what they're supposed to do with it, then I think we
> should opt for the latter every time.

EDIT: or, if "IRESTSkin" tells the web developer even more clearly how
he's supposed to use the class, then that's an even better option.  But
I'm going to defer to people with more Zope years than I have whether
the term "Layer" or "Skin" will be better here and in all of our REST
test cases.  Once it's decided, I'll happily jump in and do the renaming
myself for us.

Brandon Craig Rhodes   brandon at rhodesmill.org   http://rhodesmill.org/brandon

More information about the Grok-dev mailing list