[Grok-dev] could we re-name grok.IRESTRequest to grok.IRESTLayer?

Jan-Wijbrand Kolman janwijbrand at gmail.com
Thu Dec 18 05:17:19 EST 2008

Brandon Craig Rhodes wrote:
> EDIT: or, if "IRESTSkin" tells the web developer even more clearly how
> he's supposed to use the class, then that's an even better option.  But
> I'm going to defer to people with more Zope years than I have whether
> the term "Layer" or "Skin" will be better here and in all of our REST
> test cases.  Once it's decided, I'll happily jump in and do the renaming
> myself for us.

1) Renaming it to IRESTSkin is not an option if you'd ask me: it would
mix up the terminology involved in layers&skins:

Layers are really interfaces that extend directly or indirectly from
IBrowserRequest (or IHTTPRequest in more general cases - IRESTRequest is
a variant on IHTTPRequest). Layers can extend from other layers in order
to aggregate views.

A skin is merely a layer (thus possibly an aggregation of layers) that
is designated to be applied onto the request. That's why in Grok there's
no such thing as a "skin component" (anymore), but it through a simple
directive one'd use to designate a layer to be "applicable" onto the
request (so, this layer is then registered as being available as a skin).

In other words, I would really really not be in favor of IRESTSkin.

2) I'm still not really in favor of renaming it to IRESTLayer. But not
religiously so. I do think though, that if it is decided to have renamed
to IRESTLayer, we should consider again introducing a IBrowserLayer base
interfaces as well; I really do like to keep the symmetry here - it was
the lack of symmetry before that confused me (mind you, me as in a
developer *with* grok).


More information about the Grok-dev mailing list