[Grok-dev] Grokproject version conflict (zc.zodbrecipes 0.3.1 requires 'ZConfig>=2.4')

Sebastian Ware sebastian at urbantalk.se
Tue Jan 15 09:25:56 EST 2008

Last time I updated grokproject, easy_install automatically used  
python2.5 (macosx default) which got me into trouble Yesterday. So, I  
tried to reinstall grokproject with easy_install-2.4 -U in order to  
force it to downgrade to a python2.4 version. But when I ran  
grokproject I got the following version conflict:

$ grokproject Oink
Creating directory ./Oink
Downloading zc.buildout...
Invoking zc.buildout...
   Getting section i18n.
   Initializing section i18n.
   Installing recipe lovely.recipe.
Error: There is a version conflict.
We already have: ZConfig 2.4a6
but zc.zodbrecipes 0.3.1 requires 'ZConfig>=2.4'.

And this was what the easy_install session looked like:

$ sudo easy_install-2.4 -U grokproject
Searching for grokproject
Reading http://pypi.python.org/simple/grokproject/
Reading https://launchpad.net/grok
Best match: grokproject 0.6
Downloading http://pypi.python.org/packages/source/g/grokproject/grokproject-0.6.tar.gz#md5 
Processing grokproject-0.6.tar.gz
Running grokproject-0.6/setup.py -q bdist_egg --dist-dir /tmp/ 
Removing grokproject 0.5.1 from easy-install.pth file
Adding grokproject 0.6 to easy-install.pth file
Installing grokproject script to /usr/local/bin

Installed /usr/local/lib/python2.4/site-packages/grokproject-0.6- 
Processing dependencies for grokproject
Finished processing dependencies for grokproject

Mvh Sebastian

More information about the Grok-dev mailing list