[Grok-dev] Re: Grokproject version conflict (zc.zodbrecipes 0.3.1 requires 'ZConfig>=2.4')

Martijn Faassen faassen at startifact.com
Wed Jan 16 00:54:19 EST 2008

Sebastian Ware wrote:
> Last time I updated grokproject, easy_install automatically used 
> python2.5 (macosx default) which got me into trouble Yesterday. So, I 
> tried to reinstall grokproject with easy_install-2.4 -U in order to 
> force it to downgrade to a python2.4 version. But when I ran grokproject 
> I got the following version conflict:
> $ grokproject Oink
> Creating directory ./Oink
> Downloading zc.buildout...
> Invoking zc.buildout...
> While:
>   Installing.
>   Getting section i18n.
>   Initializing section i18n.
>   Installing recipe lovely.recipe.
> Error: There is a version conflict.
> We already have: ZConfig 2.4a6
> but zc.zodbrecipes 0.3.1 requires 'ZConfig>=2.4'.
Is it possible you already once installed Zope 3 on this machine? Old 
libraries might be lurking around in Python 2.4's "site-packages" directory.

The more I see problems like this, the more I think virtualenv would be 
the way to go. It'd be nice if we had some automatic way to get it 



More information about the Grok-dev mailing list