[Grok-dev] grokcore.view -> grokcore.browser

Philipp von Weitershausen philipp at weitershausen.de
Fri Jul 18 15:12:21 EDT 2008

Kudos to Godefroid and Lennart for factoring out view-related stuff out 
of Grok and making it work in Zope 2. May I suggest to call the package 
grokcore.browser instead of grokcore.view, though? Reasons:

1) we have different kinds of views and this package is about browser views

2) the package already contains other browser-related components (e.g. 
browser resources for CSS/JS/...)

3) it's a familiar Zope 3 naming convention (and part of factoring 
things out to separate packages is to ease adoption in pure Zope apps, 
after all).


More information about the Grok-dev mailing list