[Grok-dev] Re: grokcore.view feedback

Godefroid Chapelle gotcha at bubblenet.be
Sun Jul 20 06:38:59 EDT 2008

Philipp von Weitershausen wrote:
> Martijn Faassen wrote:
>> Godefroid Chapelle wrote:
>> [snip]
>>> I planned to propose to move Forms in a separate package 
>>> ('grokcore.formlib' ?) to avoid unneeded dependencies.
>>> And similarly, to move viewlets to 'grokcore.viewlets'.
>> Sure, I think that's reasonable (the names as well). Factoring out the 
>> form bits from grokcore.view into grokcore.formlib sounds like a good 
>> idea.
>> grokcore.viewlets will likely end up depending on grokcore.view for 
>> the template infrastructure and such, so one can debate whether the 
>> split is very useful, but it won't hurt either.
> Please let's name the package grokcore.viewlet, not only because it's in 
> analogy to zope.viewlet but also because package and module names should 
> always be singular (see PEP8). 

Definitely, that was an oversight on my side.

>> Soon nothing will be left in Grok at all anymore. :)
> Well, Grok is much about gluing things together and providing policy... 
> I think that's still going to be true...

Godefroid Chapelle (aka __gotcha) http://bubblenet.be

More information about the Grok-dev mailing list