[Grok-dev] Re: AttributeError: type object 'ISessionDataContainer' has no attribute 'isOrExtends'

Peter Bengtsson peter at fry-it.com
Sat Jun 14 07:19:48 EDT 2008

2008/6/14 Philipp von Weitershausen <philipp at weitershausen.de>:
> Peter Bengtsson wrote:
>> I tried to copycat the LoginDemo application from grokapps (with some
>> slight modifications for my usage)
>> But it get this error:
>> $ ./bin/zopectl fg
>> /home/peterbe/dev/GROK/TheGrokWay/parts/app/runzope -C
>> /home/peterbe/dev/GROK/TheGrokWay/parts/zopectl/zope.conf
>> Traceback (most recent call last):
> ...
>> AttributeError: type object 'ISessionDataContainer' has no attribute
>> 'isOrExtends'
> This has become a FAQ now: you have pickles that refer to zope.app.session,
> but the code was now moved to zope.session. Even though zope.app.session has
> backward-compatibility code for this case, your application probably no
> longer pulls in zope.app.session because it has no apparent dependency to
> that package. Workaround: make your application depend on zope.app.session
> and it should work again.
> A similar problem may occur with zope.app.securitypolicy as well.

My app does not import either zope.session or zope.app.session.
It does however import zope.app.security.interfaces

You said I should try to make it depend on zope.app.session again, so
I tried to put `import zope.app.session` on the first line of
__init__.py but it didn't help.
So, how do I make it depend on the old stuff?

>> I'm using grok 0.12.1 here.
> We should release a grok 0.12.2 that fixes this problem by depending on
> zope.app.session and zope.app.securitypolicy again.

Peter Bengtsson,
work www.fry-it.com
home www.peterbe.com
hobby www.issuetrackerproduct.com

More information about the Grok-dev mailing list