[Grok-dev] let's rename grok.baseclass() to grok.ignore()

Brandon Craig Rhodes brandon at rhodesmill.org
Tue Mar 18 17:27:28 EDT 2008

I once suggested that we rename grok.baseclass() to grok.ignore() so
that it states far more clearly what it means to the casual reader.
(Naming it grok.dont_autoconfigure_this() would be even clearer, of
course, but far too verbose.)  It was kept as "baseclass" for the
moment, if I recall, because someone claimed that you would never want
to do this to something that's not a base class.

But a fellow sprinter asked a question that has finally provided me
with a non-base-class example!  He asked: what if he wanted to
configure an object himself using ZCML, either because he was
following an example from PvW's book and didn't want to translate it
to Grok yet, or wanted to keep it ZCML to match other code he was
maintaining, or found that what he wanted to do just wasn't possible
yet with the set of Grok directives?

So ... there. :-)

I have a nagging feeling this argument will be easy to knock down, but
I'm a bit tired and will let you guys do it instead. :-)

Brandon Craig Rhodes   brandon at rhodesmill.org   http://rhodesmill.org/brandon

More information about the Grok-dev mailing list