[Grok-dev] grok_overview.html: issue with adapters

Roger Erens roger at erens-krekels.net
Tue Nov 4 10:32:01 EST 2008

on 4-11-2008 16:26 sebastian at urbantalk.se wrote:
> you are absolutely right, that's a bit of magic that only happens in a 
> hurry :)
> Anyway, to anybody who can fix it, the typo is on
>   http://grok.zope.org/doc/current/grok_overview.html
> and as Roger points out, the method sized() on:
>   DocumentSized,
>   ImageSized,
>   ContainerSized
> should probably be renamed size()
> Mvh Sebastian

Same thing a little further for the piece of code following:

'We can now make this ISized interface into the adapter factory (like 
sized above), without actually having to implement it directly. Let’s do 
that now by subclassing from grok.Adapter and using a few grok directives:'



More information about the Grok-dev mailing list