[Grok-dev] Naming of grok.provides
kevin at bud.ca
Wed Oct 15 12:14:33 EDT 2008
On Oct 15, 2008, at 12:18 AM, Thomas Lotze wrote:
> Philipp von Weitershausen wrote:
>>> But even with clearer documentation it's still somewhat confusing?
>>> grok.registers is clearer?
>> Or grok.register_for(). Consider this example::
>> class FooBar(grok.GlobalUtility):
>> grok.implements(IBar, IFoo)
> I like 'register_for' better as well. How to proceed on this now?
> write a proposal, just implement it, what about deprecation of the
> provides directive? I'm willing to implement the new name if there's
> general consent about it.
I like 'register_for', it's less confusing terminology.
More information about the Grok-dev