[Grok-dev] Naming of grok.provides
ct at gocept.com
Sat Oct 18 11:49:37 EDT 2008
On Sat, 2008-10-18 at 17:47 +0200, Thomas Lotze wrote:
> Christian Theune <ct at gocept.com> wrote:
> > register_for doesn't fit the pattern of the current terminology. The
> > current names are all declarative, whereas `register_for` sounds
> > imperative.
> Good point. The simplest fix for this seems to be `registered_for',
> though I'm not sure I like this since whether the class is actually
> registered for the stated interface depends on the way it is processed
> by Grok, not until after the programmer has made the declaration.
> Maybe a better name can be found in something that simply marks one
> interface as the "main" one in some sense, not implying its use for
> registration. OTOH this might hurt expressivity.
I thought along the lines of a 'main' interface too. But I didn't like
the syntax I could come up with either.
> Could it be that the naming problem is just a symptom of the fact that
> the directive is not actually a declaration but a processing
Christian Theune · ct at gocept.com
gocept gmbh & co. kg · forsterstraße 29 · 06112 halle (saale) · germany
http://gocept.com · tel +49 345 1229889 7 · fax +49 345 1229889 1
Zope and Plone consulting and development
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Size: 197 bytes
Desc: This is a digitally signed message part
Url : http://mail.zope.org/pipermail/grok-dev/attachments/20081018/3eb1a542/attachment.bin
More information about the Grok-dev