[Grok-dev] Grok 1.0 final?
optilude+lists at gmail.com
Wed Apr 15 10:46:02 EDT 2009
Martijn Faassen wrote:
> Martin Aspeli wrote:
>> Actually, I wouldn't name it after the context, I'd name it after the
>> module + class name. The idea is that in my source code browser, I see
>> mytype.py and templates/mytype_view.pt. It's obvious that this matches
>> mytype.py:View. If I had an Edit view in mytype.py, I'd see
>> templates/mytype_edit.pt and so on.
> Good point, that's much simpler, view module name + view class name.
Can I also ask: I'm fairly confused by the whole
default_namespace/namespace dance. Is there an actual use case for that?
Author of `Professional Plone Development`, a book for developers who
want to work with Plone. See http://martinaspeli.net/plone-book
More information about the Grok-dev