[Grok-dev] problem with megrok.kss when running the instance

Uli Fouquet uli at gnufix.de
Sat Feb 14 10:44:21 EST 2009

Hi Vanderson,

thanks for the bugreport!

Vanderson Mota dos Santos wrote:
>  Hi, i've just added 'megrok.kss' in my project's setup.py file. the
> problem is, after i ran bin/buildout and installs the library, i run
> zopectl fg this error is returned.
>  http://pastebin.com/m61792edb
> i didn't found anything about it. It keeps returning this error even
> tough i installing it into a new virtualenv.

You are using Grok 1.0a1, right? We did not check the current
`megrok.kss` release for compatibility with this Grok release (only
0.14.1 and former releases) and the error you mention, reflects such a
compatibility problem.

I just released a fixed version of megrok.kss (0.2.2) which I hope will
help you. After running::

  $ ./bin/buildout -n

this should pull the new version of `megrok.kss` and everything should
work again (hopefully).

BTW: while introspecting this problem deeper I had some trouble with the
default grok publishing process as regular grok.View instances do not
provide grok.interfaces.IGrokSecurityView. Is this intended? JSON and
REST views are not that picky, IIRC.

Best regards,


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
Url : http://mail.zope.org/pipermail/grok-dev/attachments/20090214/25276eaa/attachment.bin 

More information about the Grok-dev mailing list