[Grok-dev] The z3c.widget is broken

Steve Schmechel steveschmechel at yahoo.com
Sat Feb 14 17:12:27 EST 2009

> After adding z3c.widget into setup.py I run Buildout and get error of not
> able to download the z3c.javascript egg file.

This also effects megrok.form as it pulls in z3c.widget.

So both of these how-tos lead you to this error:

Some questions:
Why doesn't buildout find z3c.javascript?

Is "autoforms" something people really use, or does everyone create their own custom form templates?  

I tried geoHUZ's work-around, but the z3c.javascript package builds on it's own but not inside my grokproject app.

Maybe there should be an "everything in every how-to" tar file so that the documentation keeps working.  (I know it's not that easy, I'm just frustrated.)

I wanted to throw together a quick demo application for someone and I thought "autoforms" would be a time-saver.  Now I spent more time trying to make them work than I would have creating them by hand.

  Linux 2.6.27


More information about the Grok-dev mailing list