[Grok-dev] The z3c.widget is broken

TonyXu txu at userful.com
Thu Feb 19 12:57:07 EST 2009

I met this problem too. My solution is simple. Just ignore z3c.javascript. 
what you need to do for the next steps are:
1. get rid of  z3c.widget from setup.py. 
2. run build out again
3. add path of "megrok.kss-0.2.1-py2.5.egg" into <porject>/parts/app/runzope
if you are
using zopectl.

Because the previous failed buildout has already downloaded the
you just need to add the egg into path manually.

Steve Schmechel wrote:
>> After adding z3c.widget into setup.py I run Buildout and get error of not
>> able to download the z3c.javascript egg file.
> This also effects megrok.form as it pulls in z3c.widget.
> So both of these how-tos lead you to this error:
> http://grok.zope.org/documentation/how-to/automatic-form-generation/
> http://grok.zope.org/documentation/how-to/make-use-of-add-ons-via-eggs/
> Some questions:
> Why doesn't buildout find z3c.javascript?
> Is "autoforms" something people really use, or does everyone create their
> own custom form templates?  
> I tried geoHUZ's work-around, but the z3c.javascript package builds on
> it's own but not inside my grokproject app.
> Maybe there should be an "everything in every how-to" tar file so that the
> documentation keeps working.  (I know it's not that easy, I'm just
> frustrated.)
> I wanted to throw together a quick demo application for someone and I
> thought "autoforms" would be a time-saver.  Now I spent more time trying
> to make them work than I would have creating them by hand.
> Versions:
>   grok-1.0a1
>   python-2.5.2
>   Linux 2.6.27
> _______________________________________________
> Grok-dev mailing list
> Grok-dev at zope.org
> http://mail.zope.org/mailman/listinfo/grok-dev

View this message in context: http://www.nabble.com/Re%3A-The-z3c.widget-is-broken-tp22017551p22106175.html
Sent from the Grok mailing list archive at Nabble.com.

More information about the Grok-dev mailing list