[Grok-dev] could we re-name grok.IRESTRequest to grok.IRESTLayer?
faassen at startifact.com
Fri Jan 2 15:31:16 EST 2009
Jan-Wijbrand Kolman wrote:
> With a bit of reluctance, my proposal in an attempt to draw a conclusion
> and close the issue would be to:
> * Rename IRESTRequest into IRESTLayer
> * Add IViewLayer to grokcore.view.interface like so...
> IViewLayer = IBrowserRequest
> ...in order to keep backwards compatibility.
> * Change the docs in grokcore.view (and grok) in order to explain to
> use IViewLayer as a baseclass for layers.
I'm +1 with that, except I'm a bit worried that IViewLayer =
IBrowserRequest is *too* transparent. When you, say, print a layer
during debugging, it might not be immediately obvious. That said,
normally you'd print your own subclasses, so the problem wouldn't happen
very often I imagine.
I am trying to understand the backwards compatibility issues around
People can *still* inherit their own layers from IBrowserRequest if they
should desire this, after all? What am I missing?
More information about the Grok-dev