[Grok-dev] Catalog/Indexes/Search error

Paul Wilson paulalexwilson at gmail.com
Thu Jan 7 08:03:08 EST 2010

2010/1/7 Martijn Faassen <faassen at startifact.com>:
> Paul Wilson wrote:
>> 2010/1/7 Kathy Manwaring <kathy at perfectnotes.com.au>:
>>> Please, if anyone can help with this, I really need it!
>> I took the steps to recreate your problem, and experienced everything
>> that you did. Versioning problems in version.cfg,
> What are these versioning issues? Maybe I missed a message somewhere.

(mygrokproj)wilson at nightstar:~/test/testgrokproject$ grokproject grokapp
(mygrokproj)wilson at nightstar:~/test/testgrokproject$ cd grokapp
(mygrokproj)wilson at nightstar:~/test/testgrokproject/grokapp$ bin/buildout
(mygrokproj)wilson at nightstar:~/test/testgrokproject/grokapp$ vim setup.py
(add zc.catalog and hurry.query to install_requires as per tutorial)
(mygrokproj)wilson at nightstar:~/test/testgrokproject/grokapp$ bin/buildout
Develop: '/home/wilson/test/testgrokproject/grokapp/.'
Updating eggbasket.
Updating app.
  Updating app.
Error: There is a version conflict.
We already have: zope.location 3.4.0
but zope.intid 3.7.1 requires 'zope.location>=3.5.4'.

There is a versions.cfg supplied earlier on in this email trail that
has been edited to progress this issue. I've only just looked at it
and it contains the following pinned packages commented out.

#zope.index = 3.4.1
#zope.lifecycleevent = 3.4.0
#zope.location = 3.4.0
#zope.schema = 3.4.0

Probably because they caused conflict errors when building out. This
is the likely cause of the problem... I'm not sure how to get
zc.catalog working with the current versions.cfg...


More information about the Grok-dev mailing list