[ZDP] BackTalk to Document The Zope Book (2.5 Edition)/Using Zope

nobody@nowhere.com nobody@nowhere.com
Fri, 13 Sep 2002 12:35:46 -0400

A comment to the paragraph below was recently added via http://www.zope.org/Documentation/Books/ZopeBook/current/UsingZope.stx#3-30


      Zope will start running and will print logging information to
      the console. You should see information telling you what port
      Zope is listening on. You can now log into Zope with a web

        % Anonymous User - July 2, 2002 8:07 am:
         Dit is commentaar regel

        % Anonymous User - Aug. 8, 2002 2:24 pm:
         2002-08-08T17:58:11 INFO(0) ZODB Opening database for mounting: '140377936_1028827208.543770'
         2002-08-08T17:58:11 INFO(0) ZODB Mounted database '140377936_1028827208.543770' at /temp_folder
         2002-08-08T17:58:11 INFO(0) ZServer HTTP server started at Thu Aug  8 13:58:11 2002
                 Hostname: samba
                 Port: 8080
         2002-08-08T17:58:11 PANIC(300) z2 Startup exception
         Traceback (innermost last):
           File /home/dna/dope/Zope-2.5.1-linux2-x86/z2.py, line 607, in ?
           File /home/dna/dope/Zope-2.5.1-linux2-x86/ZServer/FTPServer.py, line 602, in __init__
           File /home/dna/dope/Zope-2.5.1-linux2-x86/ZServer/medusa/ftp_server.py, line 727, in __init__
           File /home/dna/dope/Zope-2.5.1-linux2-x86/ZServer/medusa/asyncore.py, line 306, in bind
         error: (98, 'Address already in use')

        % Anonymous User - Aug. 8, 2002 2:27 pm:
         error (98, 'Address already in use')
         any ideal

        % Anonymous User - Aug. 13, 2002 9:39 am:
         Check to see if you have anything running on port 8021 (such as an FTP server or somesuch...) Zope tries to
         start an additional FTP server on port 8021.
         Sean Bossinger

        % Anonymous User - Aug. 27, 2002 12:28 pm:
         i installed the binaries of the 2.5.1 version. when i run the install script, after the ZServer PCGI Server
         started, i obtain the message
         z2 Startup exception
         File /etc/Zope-2.5.1-linux2-x86/z2.py, line 690 , in ?
         IO Error [Errno 13] Permission Denied: '/etc/Zope-2.5.1-linux2-x86/z2.pid'

         what's wrong?

         Luca Morelli

        % Anonymous User - Aug. 27, 2002 12:30 pm:
         ... when i run the start script ...

         Luca Morelli

        % fleximan - Sep. 13, 2002 5:47 am:
         I've got ecxactly the same problems here andt don't know how to get it running :-(

        % Anonymous User - Sep. 13, 2002 12:35 pm:
         Have you looked at line 690 in z2.py to see what it is trying to do? The 'permission denied' error messages
         often result from zope trying to write the .pid file as user 'nobody' to a directory that has only root
         permissions. With all the Zope's I've installed on *nix, I've had to chmod some things first.