[ZODB-Dev] KeyError / POSKeyError

Tim Tisdall tisdaltn at mcmaster.ca
Fri Mar 23 12:04:08 EDT 2007

  I've got a 1gb ZODB that contains a single plone site and I'm not
able to access any part of it via the ZMI.  It keeps saying that it's
looking for key "fammed-old" which is another plone site in another
ZODB file.  Basically I managed to partly migrate a Plone 2.0 to Plone
2.5 and then copied over the file contents from that instance into a
new Plone instance.  I have no idea why the new one would be
referencing the old one, but it seemed to always throw this error if
the old database was unmounted.
  I've tried several "cookbook" fixes I've found, but the problem is
that the plone instance itself is throwing the KeyError.  Deleting the
whole plone instance is not going to help me much.  Any suggestions?
  I've also tried running the fsrecovery.py, but it simply makes a
complete duplicate of the file.  fstest.py doesn't seem to find any
errors.  fsrefs.py finds a series of errors, but I have no idea what
to do with that information.  It seems that it's finding that it's
referencing "fammed-old" and that that doesn't exist.


More information about the ZODB-Dev mailing list