[Zope-Checkins] CVS: Zope/lib/python/ZPublisher/tests - testBaseRequest.py:1.4

Jeremy Hylton jeremy at zope.com
Fri Feb 27 14:35:51 EST 2004

Update of /cvs-repository/Zope/lib/python/ZPublisher/tests
In directory cvs.zope.org:/tmp/cvs-serv22939

Modified Files:
Log Message:
Calling Zope.startup() seems to cause the tests to die.
Removing the import and call allows the tests to pass.

This code is a complete mystery.  It wasn't failing when I ran the
tests yesterday.  But if I do a checkout -D "yesterday," it fails with
an error on the Zope.startup() call.  It looks like that code should
have always failed.  No idea how it ever worked.

=== Zope/lib/python/ZPublisher/tests/testBaseRequest.py 1.3 => 1.4 ===
--- Zope/lib/python/ZPublisher/tests/testBaseRequest.py:1.3	Tue Nov 18 08:17:18 2003
+++ Zope/lib/python/ZPublisher/tests/testBaseRequest.py	Fri Feb 27 14:35:50 2004
@@ -1,8 +1,5 @@
 from unittest import TestCase, TestSuite, makeSuite, main
-import Zope
 from Acquisition import Implicit
 from ZPublisher.BaseRequest import BaseRequest
 from ZPublisher.HTTPResponse import HTTPResponse

More information about the Zope-Checkins mailing list