[Zope-PTK] Portals not importable.

Bill Anderson bill@libc.org
Sat, 01 Apr 2000 20:37:18 -0700

OK, I see this as a major issue. I have tried exporting portals, and
reimporting them, with absolutely Zero success. I have just tried a set
of tests on 2.1.6 w/0.7.1, on Linux. and a freshly created Portal. I
exported it, and it was not importable, returning:

Error Type: UnpicklingError
Error Value: invalid load key, '>'.

Traceback (innermost last):
  File /home/web/Tester/lib/python/ZPublisher/Publish.py, line 214, in
  File /home/web/Tester/lib/python/ZPublisher/Publish.py, line 179, in
  File /home/web/Tester/lib/python/Zope/__init__.py, line 202, in
    (Object: ApplicationDefaultPermissions)
  File /home/web/Tester/lib/python/ZPublisher/Publish.py, line 165, in
  File /home/web/Tester/lib/python/ZPublisher/mapply.py, line 160, in
    (Object: manage_importObject)
  File /home/web/Tester/lib/python/ZPublisher/Publish.py, line 102, in
    (Object: manage_importObject)
  File /home/web/Tester/lib/python/OFS/ObjectManager.py, line 484, in
    (Object: ApplicationDefaultPermissions)
  File /home/web/Tester/lib/python/ZODB/ExportImport.py, line 284, in
UnpicklingError: (see above)

I get these on _any_ Zope export/import; whether same-zope/machine, or
differing Zopes.

I am curious as to whether or not anyone else is having this problem, or
is it just me and my machines? :/ 

For those of us who do devel on one server, and deploy to another, or
upgrade through this method, or backup with this method, this is a show

Any fixes _very_ appreciated.


In flying I have learned that carelessness and overconfidence are 
usually far more dangerous than deliberately accepted risks. 
          -- Wilbur Wright in a letter to his father, September 1900