Chris Withers chrisw@nipltd.com
Mon, 31 Jul 2000 22:43:05 +0100

Shane Hathaway wrote:
> This sounds like a great idea, Phillip.  Just a few new lines of code
> and we instantly get a refinement of the Zope object model.  That's
> cool.

I really like this :-)))

> Three states would be available (should all three states have names?):

Yes! No meaningless numbers please ;-)

How about:
> __replaceable__ = ObjectManager.NOT_REPLACEABLE # current
> behavior
> __replaceable__ = ObjectManager.REPLACEABLE # instance config
> __replaceable__ = ObjectManager.SINGLETON   # singleton


> There already is a _.this, it's set to the DTMLMethod or Document that
> first created the namespace.  

Is that the same as this() or something different?!

> But we could add a _.self.  That would
> solve the keyword problem.  One line of code.  One word: wow.

Cool :-)

I'm off to dev.zope.org...