[Zope-CMF] [dev] CMFDefault skins
Thu, 27 Feb 2003 15:17:34 +0100
Chris Withers wrote:
> Yuppie wrote:
>> I decided to rewrite these forms and move the common code into a new
>> template called 'workflow_template.pt'.
>> Please let me know if you think this is a Bad Idea or if you got a
>> better idea.
> I think the setup should be changed so there is only one form to change
> the state of a piece of content.
I was afraid someone would propose this ;)
Sounds like a Good Idea, but it's a bigger change than I want to do
right now. AFAICS this needs
- workflow action changes
- storing transition descriptions somewhere else (in the workflow?)
- a migration path
But I think 'transition_form.pt' would be a better name than
'workflow_template.pt'. If someone implements what you propose,
'transition_form.pt' could be also used for that.