[Zope-CMF] Re: Missing docstring in LocalFS?

Rainer Thaden thadi at gmx.de
Tue Oct 21 08:20:33 EDT 2003

Hi again,

after some more googling we found a solution. The ObjectWrapper class in 
line 294 in LocalFS.py needs to have a docstring. Changed it to

         class ObjectWrapper(Wrapper, c):
	    """ ObjectWrapper """

and it works again. Seems to have to do with python 2.2.

Rainer Thaden wrote:

> Hi all,
> i have a CMF Site running at our lab and we have some resources in the 
> file system which are accessed via LocalFS.
> Until this morning everything worked fine.
> Now i get an error when i try to access objects via LocalFS:
> "Zope has encountered a problem publishing your object.<p>
> The object at https://www.akustik.rwth-aachen.de/pub/images/general.css 
> has an empty or missing docstring. Objects must have a docstring to be 
> published."
> I found a thread in the german zope user group site dealing with the 
> same problem. There it is recommended to add a docstring to the LocalFS 
> class. Unfortunately in my LocalFS product there _is_ a docstring, so 
> that doesn't seem to be the problem.
> As i said, until this morning everything worked. Maybe there was a 
> debian update which ruined the whole thing.
> I am able to browse the Local file system via Zope. Only the files 
> inside can not be displayed.
> We are running Zope under debian, seems to be Zope 2.6.2-2
> LocalFS Version: 1.0
>  From the control panel i get
> Zope Version (unreleased version, python 2.2.3, linux2)
> Python Version 2.2.3+ (#1, Sep 30 2003, 01:19:08)
> [GCC 3.3.2 20030908 (Debian prerelease)]
> System Platform linux2
> I have the same system (Zope 2.6.2) running under Win2k and there 
> everything works fine.
> Any ideas?

More information about the Zope-CMF mailing list