[Zope-CMF] Problems installing type into portal

antonh at lawtec.net antonh at lawtec.net
Tue Mar 2 17:59:55 EST 2004

Hi Dieter,

> Install this product only, where there is no other "catalog" activity
> (modifications, to be precise).
So I guess I should try installing it late at night when nobody is using
the portal then...

> Usually, an isolated "ConflictError" is not problem. The
> request should simply be retried.
> However, some products are stupid about catching exceptions.
> More precisely, they catch "ConflictError", too. This
> prevents the automatic retrial.
> The second exception ("not registered") is almost surely more
> interesting...
> Do you get a traceback?

No, I don't get a traceback. I've tried manually running the installer's
external method and I get the same result. I've also tried to add this new
content type through the ZMI as a Factory Type Information object, but it
isn't in the list.

It seems like the ConflictError I got on the first installation attempt
has somehow fooled the installer into thinking that the type has been
registered when it has not, so it is skipping this step on subsequent
attempts. Is there a way that I can 'manually' force the registration of
my new type with the portal again?



More information about the Zope-CMF mailing list