[Zope-CMF] Small CMFCatalogAware refactoring

Jean-Marc Orliaguet jmo at ita.chalmers.se
Mon Sep 12 08:36:21 EDT 2005

Sidnei da Silva wrote:

>On Mon, Sep 12, 2005 at 02:03:24PM +0200, Jean-Marc Orliaguet wrote:
>| Hi Sidnei
>| the difference is that portal_catalog is both a tool and a catalog
>| instance (with its indexes, records...). Other CMF tools are just tools
>| and their path can well be hardcoded in CMF since they provide only
>| functionality.
>That's not good enough of an argument for me. Are you suggesting that
>in some places it's used as 'catalog' and in some places it's used as
>'tool'? If that's the case, then we should identify such places and
>use different 'tokens' for each use. Eg: 'portal_catalog' and
>'portal_catalog_tool' or something.
>Still, the place to add indirection would be 'getToolByName'. As Tres
>said above, let's not invent another component architecture.

I agree that the correct of doing it is through the equivalent of a
getUtility(IToolInterface, name=''), but there is a need for this now.

the _getWorkflowTool() hook was accepted by the way. Why is this different??


More information about the Zope-CMF mailing list