[Zope-CMF] Re: [dev] five.localsitemanager: proposal

Hanno Schlichting plone at hannosch.info
Mon Jun 25 04:35:06 EDT 2007

yuppie wrote:
> Hi Hanno!
> Hanno Schlichting wrote:
>> Starting any Plone tests will give an AttributeError on self.adapters in
>> the subscribers method of zope.component.registry.
>> The registry is actually the one from five.lsm and is found via the
>> zope.app.component.hooks.SiteInfo container. In there it is available as
>> the sm property, but it indeed at that point lacks the adapters
>> attribute. It looks like _init_registries is never called. But when I
>> overwrite the set method on SiteInfo every time a new sm is set, it has
>> the right adapters.
> Strange. five.lsm is just messing around with 'utilities', not with
> 'adapters'. 'adapters' should work exactly the same way as in a pure z3
> site manager.
> Can't see how the latest five.lsm changes could cause that problem.

Me neither :( But as said the sitemanager I get back, though it is the
one from five.lsm, has neither an adapters nor utilities or name set.

>> I didn't have time to test this properly but maybe this gives somebody
>> else an idea who wants to look at it...
> What's your testing environment?
> https://svn.plone.org/svn/plone/bundles/3.0/EXTERNALS.txt
> uses r76995 of CMF and
> https://svn.plone.org/svn/plone/bundles/3.0-lib/five/EXTERNALS.txt
> uses five.localsitemanager/trunk

I use https://svn.plone.org/svn/plone/ploneout/trunk and updated CMF to
the HEAD revision. Which is pretty much identical to the above bundles.

> I expect you can get Plone running with CMF 2.1 branch HEAD and the old
> five.lsm, but not with the five.lsm trunk and r76995 of CMF.

Haven't actually tried that. Good point.

> Are you using a KSS version without monkey patch?

I tried with both with and without the KSS monkey but it doesn't seem to
have any effect.


More information about the Zope-CMF mailing list