[Zope-CMF] [dev] 'add' actions and views - a proposal
y.2008 at wcm-solutions.de
Sun Sep 21 11:54:48 EDT 2008
Wichert Akkerman wrote:
> Previously Martin Aspeli wrote:
>> I don't feel particularly strongly either way, so long as there's an
>> actual namespace rather than a naming convention and we avoid an
>> IPublishTraverse adapter for all IFolderish.
>> ++add++PortalType is a bit uglier than /@@add/PortalType IMHO, but it's
>> a transient URL so it doesn't really matter.
> It makes it more explicit that there is no real @@add 'thing' that
> is traversed over.
>> I think it's worth finding out why we have +/IAdding being a view and
>> not a namespace traversal adapter, though. It feels that things like
>> ++skin++ or ++vh++ are a bit different to ++add++, though perhaps not.
> The + naming for IAdding has always been a mystery to me. It feels very
> out of place considering that it is just about traversing into a
> add-view namespace.
In Zope 3 '+' *is* a real page with content. Maybe that's the reason?
Anyway. I like the idea to use a traverser. It's more explicit and if
you want different URLs you can hide them behind aliases.
More information about the Zope-CMF