[Zope-CMF] [dev] five.localsitemanager: dependencies

yuppie y.2009 at wcm-solutions.de
Thu Feb 12 08:45:05 EST 2009


I have some trouble using five.localsitemanager in a buildout with Zope2 
2.12.dev. This is the error I get:

   Error: There is a version conflict.
   We already have: zope.location 3.5.3
   but Zope2 2.12.dev requires 'zope.location==3.5.2'.

The setup.py of five.localsitemanager specifies these dependencies:

         'zope.component >= 3.5.0',
         'zope.location >= 3.5.0',
         'zope.site >= 3.6.0',

If I remove the dependencies that are also part of the Zope2 2.12.dev 
dependencies everything works fine:

         'Zope2 >= 2.12.dev',

Is that the right way to resolve that issue? Could it cause any trouble 
if I would check in that change?



More information about the Zope-CMF mailing list