[Zope-DB] Issues of MySQLdb and ZMySQLDA

Martin Gebert Murphy@members.netsolution-net.de
Fri, 20 Dec 2002 18:56:21 +0100

Dieter Maurer schrieb:

>Martin Gebert writes:
> > Some time ago I came across two issues with MySQLdb and ZMySQLDA, which 
> > I reported to Andy Dustman, owner of this two Products. I didn't get any 
> > answer until today, so I'd like to publish these on this list in the 
> > hope that someone more into this code could have an eye on it.
> > 
> > --------------------------
> > 
> > First, I ran into problems when I tried to do
> > 
> > from MySQLdb import *
> > 
> > in Python 2.1.3 (console) due to missing attributes in that package 
> > (some date and time attributes or functions). Deleting the referring 
> > declarations from the __init__.py/__all__ list seemed to work...
>Looks fine.
>Send him the patch.
>Maybe place it in your member area on "Zope.org", too, such that others
>can use it.
OK, this problem had already been solved. I connected Andy succesfully 
and he told me that there's a new version of MySQLdb (MySQL-python) on 


You can find this link also on the MySQLdb page at Zope in the menu on 
the left...