[Zope-DB] win32 odbc DA constantly losing connection

T. Muddletin x@Vex.Net
Wed, 26 Feb 2003 03:10:38 -0500

I've been having a very annoying time with zope's ODBC DA, on windows.
After a half dozen or so queries it would lose its connection to a
postgresql database (running on freebsd on the lan).

When i'd try to re-"open" the database in zope i'd get "Invalid
connection string: dsn" (where 'dsn' is the name of the odbc data

Yet the data source is okay. Other apps maintain their connection. The
only way i seem to get zope to reconnect though is to shut it down and
restart it completely.

In desperation searching for alternatives i finally got slightly old
psycopg working using the binary found on zope.org at
http://www.zope.org/Members/pvl/PsycopgWin32 and I was a (relatively)
happy camper again... things seemed grand.

And then suddenly this DA lost its connection also. Distressing!
However, there was a difference... when i tried to re-open this
connection i see the error: "psycopg.OperationalError FATAL: Sorry,
too many clients already"

AH!! So that's it! Now at least I know what seems to be the actual
problem. I'm still not happy about the DA completely shutting down...
what's it doing with all those other connections it is holding open?
But at least now I can try to work with the problem and increase the
connections available in postgresql or something.

Bloody unhelpful ms ODBC error messages!

Okay, back to work now.

Tim Middleton | Cain Gang Ltd | I have lived through whole tragedies
x@veX.net     | www.Vex.Net   | without speaking a word. --Dost. (GC)