[Zope-DB] DCOracle2 // Python 2.3 // Oracle9i Compile Problems

Sorisio, Chris ChrisSorisio at PeakTechnical.com
Thu Sep 4 13:42:16 EDT 2003

Hola folks,

I'm having trouble compiling DCOracle2, which is weird because it compiled
and worked fine against Python 2.2.  When I tried to compile it against
Python 2.3, it gave the error detailed below.  The only other difference I
can pick out is that I didn't use "official" Red Hat RPMS to install Python
2.3 - I used the pydotorg RPMS.

Any suggestions?



=================Compile Log====================

[oracle at ssupp003 DCOracle2]$ make
(cd src; \
./testora python)
Checking ORACLE_HOME...passed.
Checking for Oracle version...Oracle 9i found.
(cd src; \
cp -p Setup.in Setup )
(cd src; \
make -f Makefile.pre.in boot PYTHON=python || ./setuperrors; \
make dummy || ./setuperrors)
make[1]: Entering directory `/home/oracle/dco/DCOracle2/src'
rm -f *.o *~
rm -f *.a tags TAGS config.c Makefile.pre python sedscript
rm -f *.so *.sl so_locations
VERSION=`python -c "import sys; print sys.version[:3]"`; \
installdir=`python -c "import sys; print sys.prefix"`; \
exec_installdir=`python -c "import sys; print sys.exec_prefix"`; \
make -f ./Makefile.pre.in VPATH=. srcdir=. \
        installdir=$installdir \
        exec_installdir=$exec_installdir \
make[2]: Entering directory `/home/oracle/dco/DCOracle2/src'
sed -n \
 -e '1s/.*/1i\\/p' \
 -e '2s%.*%# Generated automatically from Makefile.pre.in by sedscript.%p' \
 -e '/^VERSION=/s/^VERSION=[    ]*\(.*\)/s%@VERSION[@]%\1%/p' \
 -e '/^CC=/s/^CC=[      ]*\(.*\)/s%@CC[@]%\1%/p' \
 -e '/^CCC=/s/^CCC=[    ]*\(.*\)/s%#@SET_CCC[@]%CCC=\1%/p' \
 -e '/^LINKCC=/s/^LINKCC=[      ]*\(.*\)/s%@LINKCC[@]%\1%/p' \
 -e '/^OPT=/s/^OPT=[    ]*\(.*\)/s%@OPT[@]%\1%/p' \
 -e '/^LDFLAGS=/s/^LDFLAGS=[    ]*\(.*\)/s%@LDFLAGS[@]%\1%/p' \
 -e '/^DEFS=/s/^DEFS=[  ]*\(.*\)/s%@DEFS[@]%\1%/p' \
 -e '/^LIBS=/s/^LIBS=[  ]*\(.*\)/s%@LIBS[@]%\1%/p' \
 -e '/^LIBM=/s/^LIBM=[  ]*\(.*\)/s%@LIBM[@]%\1%/p' \
 -e '/^LIBC=/s/^LIBC=[  ]*\(.*\)/s%@LIBC[@]%\1%/p' \
 -e '/^RANLIB=/s/^RANLIB=[      ]*\(.*\)/s%@RANLIB[@]%\1%/p' \
 -e '/^MACHDEP=/s/^MACHDEP=[    ]*\(.*\)/s%@MACHDEP[@]%\1%/p' \
 -e '/^SO=/s/^SO=[      ]*\(.*\)/s%@SO[@]%\1%/p' \
 -e '/^LDSHARED=/s/^LDSHARED=[  ]*\(.*\)/s%@LDSHARED[@]%\1%/p' \
 -e '/^CCSHARED=/s/^CCSHARED=[  ]*\(.*\)/s%@CCSHARED[@]%\1%/p' \
]*\(.*\)/s%@LINKFORSHARED[@]%\1%/p' \
 -e '/^prefix=/s/^prefix=\(.*\)/s%^prefix=.*%prefix=\1%/p' \
'/^exec_prefix=/s/^exec_prefix=\(.*\)/s%^exec_prefix=.*%exec_prefix=\1%/p' \
 /usr/lib/python2.3/config/Makefile >sedscript
echo "/^#@SET_CCC@/d" >>sedscript
echo "/^installdir=/s%=.*%=     /usr%" >>sedscript
echo "/^exec_installdir=/s%=.*%=/usr%" >>sedscript
echo "/^srcdir=/s%=.*%=         .%" >>sedscript
echo "/^VPATH=/s%=.*%=          .%" >>sedscript
echo "/^LINKPATH=/s%=.*%=       %" >>sedscript
echo "/^BASELIB=/s%=.*%=        %" >>sedscript
echo "/^BASESETUP=/s%=.*%=      %" >>sedscript
sed -f sedscript ./Makefile.pre.in >Makefile.pre
/usr/lib/python2.3/config/makesetup \
         -m Makefile.pre -c /usr/lib/python2.3/config/config.c.in Setup -n
make -f Makefile do-it-again
make[3]: Entering directory `/home/oracle/dco/DCOracle2/src'
/usr/lib/python2.3/config/makesetup \
         -m Makefile.pre -c /usr/lib/python2.3/config/config.c.in Setup -n
make[3]: Leaving directory `/home/oracle/dco/DCOracle2/src'
make[2]: Leaving directory `/home/oracle/dco/DCOracle2/src'
make[1]: Leaving directory `/home/oracle/dco/DCOracle2/src'
make[1]: Entering directory `/home/oracle/dco/DCOracle2/src'
make[1]: `dummy' is up to date.
make[1]: Leaving directory `/home/oracle/dco/DCOracle2/src'
( cd src; \
make || ./builderrors)
make[1]: Entering directory `/home/oracle/dco/DCOracle2/src'
gcc -pthread -fPIC -DNDEBUG -g -O3 -Wall -Wstrict-prototypes
-I/usr/include/python2.3 -I/usr/include/python2.3 @DEFS@
-I/opt/oracle/product/9.2.0/rdbms/public -DORACLE9i -c ././dco2.c -o
gcc: cannot specify -o with -c or -S and multiple compilations
make[1]: *** [dco2.o] Error 1
make[1]: Leaving directory `/home/oracle/dco/DCOracle2/src'
There were errors building the dco2 module.  This could be because of a

More information about the Zope-DB mailing list