[Zope-DB] Transaction Weirdness

Dieter Maurer dieter at handshake.de
Sun Sep 14 15:46:12 EDT 2003

Christian Theune wrote at 2003-9-10 07:45 +0200:
 > ...
 > we are discovering a problem loosing data with PyPgSQL/ZPyPgSQLDA,
 > Postgres 7.3.2 and Zope HEAD (as of 2003/07/14).
 > Effect is that sometimes the DA seems to keep a connection to postgres
 > around in "idle in transaction" state (most times without any write
 > queries up to this time) and sometimes holds it for quite a while. We
 > can reproduce it at about 50% of the time which results in data loss,
 > when the query that keeps hanging around had write accesses, remains
 > open and get's a rollback due to an exception in a later request.
 > Anybody familiar with this problem?

Both me and a colleague independently met a similar problem.

Turned out that both of us made the same error:

  We both worked on an object relational mapping.
  In order not to write the database for each modified
  attribute, we delayed writing to the database until
  At that time, however, the transaction had already
  determined all objects that should take part in the
  transaction. The PostgresDA registered too late and
  was "forgotten".

Not sure, you see the same problem.

Aside from this error on our part, we never lost commits to


More information about the Zope-DB mailing list